2014年6月11日水曜日

Android Studio - Version 0.6.0 バージョンアップ後のエラー

Android Studio 0.6.0へのバージョンアップ後のエラー、

Error:Cause: unexpected end of block data

の対策メモ。

1. プロジェクトルート直下にある「build.gradle」を開き、
dependencies {
    classpath 'com.android.tools.build:gradle:0.9.+'
}
のところを、
dependencies {
    classpath 'com.android.tools.build:gradle:0.11.+'
}
に変更します。


2. 「src」直下にある「build.gradle」を開き、buildToolsVersionを「19.1.0」に変更します。
android {
    buildToolsVersion "19.1.0"
}
 
3. 「Android SDK Manager」 を実行し、「Tools」-「Android SDK Build-tools 19.1」をインストールします。
 
 
これで、エラーは解消されるはず。
 
 
こんなところで。