2014年3月7日金曜日

Android Studio - Version 0.5.0 でGradle plug-inエラー

Android Studioのバージョンが、0.5.0になったので、バージョンアップしたら、

The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.

のエラーが出て、ビルド出来なくなってしまったので、対策メモ。

プロジェクトルート直下にある「build.gradle」を開き、
dependencies {
    classpath 'com.android.tools.build:gradle:0.8.+'
}
のところを、
dependencies {
    classpath 'com.android.tools.build:gradle:0.9.+'
}
に変更します。

変更後、「Sync Project with Gradle Files」ボタンを押すと、新しいバージョンのGradle plug-in がダウンロードされて、正常にビルドができるようになります。

参考:
Getting Started with Android Studio | Android Developers
Android Studio 0.5.0 Released


こんなところで。

0 件のコメント:

コメントを投稿